- Member Audio::Mixer::isReady () const =0
- get rid of this?
- Class Common::ConfigManager
- Implement the callback based notification system (outlined below) which sends out notifications to interested parties whenever the value of some specific (or any) configuration key changes.
- Member Common::ErrorCode
- Adjust all error codes to comply with these conventions.
- Member Common::EventType
- Merge EVENT_LBUTTONDOWN, EVENT_RBUTTONDOWN and EVENT_WHEELDOWN; likewise EVENT_LBUTTONUP, EVENT_RBUTTONUP, EVENT_WHEELUP. To do that, we just have to add a field to the Event which indicates which button was pressed.
- Member Common::FSNode::getChild (const String &name) const
- If createWriteStream() (or a hypothetical future mkdir() method) is used, this should affect what exists/isDirectory/isReadable/isWritable return for existing nodes. However, this is not the case for many existing FSNode implementations. Either fix those, or document that FSNodes can become 'stale'...
- Member Common::FSNode::isDirectory () const
- Currently we assume that a node that is not a directory automatically is a file (ignoring things like symlinks or pipes). That might actually be OK... but we could still add an isFile method. Or even replace isDirectory by a getType() method that can return values like kDirNodeType, kFileNodeType, kInvalidNodeType.
- Member Common::normalizePath (const String &path, const char sep)
- remove double dot components: /foo/baz/../bar -> /foo/bar
- Class Common::SeekableReadStream
- Get rid of SEEK_SET, SEEK_CUR, or SEEK_END, use our own constants
- Class Common::Serializer
Maybe rename this to Synchronizer?
One feature the SCUMM code has but that is missing here: Support for syncing arrays of a given type and *fixed* size; and also support for when the array size changed between versions. Also, support for 2D-arrays.
Proper error handling!
- Member Common::Serializer::syncString (String &str, Version minVersion=0, Version maxVersion=kLastVersion)
- Replace this method with a special Syncer class for Common::String
- Member Engine::syncSoundSettings ()
- find a better name for this
- Class Graphics::Font
- Maybe move the high-level methods (drawString etc.) to a separate FontRenderer class? That way, we could have different variants... ?
- Class MidiDriver
- Rename MidiDriver to MusicDriver
- Member MidiDriverFlags
- Rename MidiDriverFlags to MusicDriverFlags
- Member OSystem::addSysArchivesToSearchSet (Common::SearchSet &s, int priority=0)
- Come up with a better name. This one sucks.
- Member Video::VideoDecoder::setRate (const Common::Rational &rate)
- This currently does not implement backwards playback, but will be implemented soon.
Generated on Sat Feb 15 2020 05:01:41 for ResidualVM by 1.7.1